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A LAT flight software document template.

Designed for use with documents version controlled through the flight software code repository. This template is suitable for both short and long documents (a short document is simply a single section long document).

Includes special features to support the documentation of code/session/file extracts. 
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0 Introduction

This is an attempt to set up a document template for GLAST/LAT flight software documents. This is the first entry in what I hope will become a series of templates.

0.0 Why Set Up A Template?

The purpose of a template is to relieve the document writer of the need to manage all the stylistic aspects of a document leaving the writer free to concentrate on the content of the document. How far this separation can be taken depends on the sophistication of the tools provided by the word processor used. Word has some pretty sophisticated tools available, though their use is sometimes a little obscure. In particular, this template takes considerable advantage of Word ‘fields’ which are complicated enough to warrant some explanation.

0.1 Dealing With Fields

A field is a piece of ‘meta-text’. A simple example is the title of the document. The title is entered, not in the body of the document but via the Properties entry in the File menu. What is entered in the document is in fact a ‘placeholder’ which Word promises to substitute with the definition from the properties sheet. It does this on the fly, so the proper title always appears on the front page (and elsewhere).

That’s cool, but can lead to confusion. Suppose the writer needs to edit the title? Natural instinct says to select the old title and replace it with a new title. This doesn’t work too well because what actually happens is that the placeholder is deleted (what the writer should really do of course is pull up the properties sheet and edit the title in there). How can the writer avoid this trap? Here are a couple of useful tips:

· There is a visual clue when a field is selected. If the insertion point is located using a single click in some regular text, the insertion point flashes but nothing happens to the word which contains the insertion point. Try the same thing in a field and all the text substituted in by the placeholder turns grey.

· A much more powerful technique is to tell word to stop substituting the placeholder text. This mode can be toggled using Alt-F9. In this mode, the title (for instance) will change to read:

{ TITLE  \* MERGEFORMAT }

Fields can be used to automate away many otherwise tedious tasks. This template uses them to generate:

· Page numbers.

· Text in headers and footers.

· Figure and table numbering.

· All the ‘front matter’ (table of contents, table of figures, etc.).

Unfortunately, Word’s implementation of placeholder substitution is not always consistent. Page numbers for instance are always updated on the fly and are always right. Figure captions on the other hand are only updated at certain operations (when saving or printing a file) or on demand (use the right mouse button to select a piece of placeholder text and select Update Field from the pop-up menu). Front matter is only updated on demand. The best solution I have for updating absolutely every field in a document is to Edit/Select All (or cntl-A), right click anywhere in the document, then pick Update Field from the pop-up menu. This will go through everything, including refreshing all front matter (Word will prompt the user for update method for each table … pick Update entire table).

0.2 Layout Of This Document

A typical document these days is prepared in reverse order from the way it’s read. First a lot of body text is written with a bunch of headings to break the text into logical sections. Then the front matter is added and then a front page slapped on. Because this is a template for document writers, the sections which follow will travel the writing path and not the reading path.

0.3 Font Wars

In putting this template together, I had to set up a variety of ‘style sheets’ to format headers, footers, the outlining style and so on. Among the myriad options I of course had to select fonts. Now font wars are notorious. I don’t suppose I’ll satisfy everyone’s taste, but please accept that my choices weren’t entirely capricious. It is particularly awkward to find a font or combination of fonts that will look good in all the forms in which they’ll appear. I’m sure that even this document will turn up both on people’s screens and on paper, and that it will be converted to PDF format (and then appear both on screens and on paper). I finally settled on Arial for almost everything because it’s a very ‘clean’ font (no serifs or other decoration), widely available and converts well to PDF. For those who have seen previous documents from me, you will notice that I have given up with the use of italics in headers. I still think it looks pretty cool in Word, but it looks awful when converted to PDF.

1 Basic Document Elements

1.0 Body Text

Body text is what you’re reading now. I hope I don’t have to spend too much time on how to enter and format body text. About the only thing you need to know is that to format a block of text to conform to the document style, select a paragraph or paragraphs of text, then pull down the list of style sheets in the appropriate toolbar and select Body.

1.1 Headings

To break a long document into logical chunks, use ‘headings’ (not to be confused with ‘headers’). This template supports headings down to a depth of six and they look like this:

1.1.0 Heading Level 3

1.1.0.0 Heading Level 4

1.1.0.0.1 Heading Level 5

1.1.0.0.1.1 Heading Level 6

I left out level 2 because I wanted the body text I’m typing now to be grouped under the level 2 heading ‘Headings’. Level 1 headings are a bit special and I’ll cover those later.

To insert a heading or change the level of an existing heading simply select the text, pull down the style sheet list in the toolbar and select the heading level you want.

More importantly, the heading styles are tied to the document outline. Try playing around changing the heading levels and you’ll notice that they automatically renumber.
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	I confess I had a bit of fun with the numbering scheme. Being a longtime C programmer I’m quite convinced that numbering schemes start at zero and the heading numbers reflect that. If there are severe objections I can always change it back.


There are a number of upsides to this arrangement:

· The document writer doesn’t have to go round keeping the heading numbers straight.

· As you’ll see later, the headings can be auto-formatted into a table of contents.

1.2 Heading 1 And Sections

The highest level of organization in a document is the level 1 heading. In this template, the level 1 heading has been bound to a ‘section’ as defined by the Word program. In documents based on this template, there should be one and only one level 1 heading per section and it should be the first thing to appear in the section (the text ‘Basic Document Elements’ is the level 1 heading for this section). The section break before a level 1 heading can be inserted as follows:

· Put the insertion point at the front of a level 1 heading.

· Pull down the Insert Menu and select Break… .
· In the resulting window under Section break types, select Next page.
· Click OK.
You may notice that contrary to the instructions above, this template uses a couple of Section Break (Odd Page) breaks. In the traditional publishing world it would be standard practice to always use a Section Break (Odd Page) before a new section (or chapter) to start it on an odd (right hand) page. Check it out the next time you’re reading a book (right hand pages are always odd, though starting chapters on a right hand page seems to be falling into abeyance). For a project document I didn’t think it was necessary to be this hidebound (and it relieves the necessity of those silly statements like ‘This Page Deliberately Left Blank’). The Section Break (Odd Page) breaks remaining in this template are there to ensure that where page sequence numbers start, they start on the right hand page (notice that the front matter and the body use different numbering sequences … the front matter uses roman numerals and the body uses arabic).

This usage of level 1 headings and sections may sound very restrictive, but there’s method in my madness. Establishing these rules allows me to take advantage of another Word trick, but I’ll leave the description of that to the section covering ‘Headers And Footers’.

1.3 Tables

OK, you’ve written huge volumes of documentation and now you want to put in the front matter. This template supports the generation of three types of tables:

· Contents.

· Figures.

· Tables.

1.3.0 Table Of Contents

The table of contents is generated from the outline headings so you have in effect done all the work already. To create or update the tables of contents:

· If this is a new table of contents, put the insertion point before the paragraph mark below the title string ‘Contents’. If the table already exists, click anywhere in the left hand margin next to it (depending on exactly where you click, either all lines in the table will turn black or just the line you clicked next to will turn black and the rest of the table will turn grey).

· Pull down the Insert menu and select Index and Tables… .
· In the resulting window, select the Table of Contents tab.

· Click OK.
· If asked Do you want to replace the selected table of contents, click Yes.
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	At time of writing, there are still some anomalies in the styles applied to the text in the table of contents (the generation process seems to insert an extra tab mark for unknown reasons). I’ve wasted hours on this without curing it. If you want the spiffy version of the table of contents you will need to do a minor edit after regenerating it. Put the arrow in the left margin adjacent to the first section title and click. The whole table should turn black. Go up to the hanging indent marker in the ruler at the top and hover over it until a little drop down label says ‘Left Tab’. Click and hold to grab the tab and drag it off the page. All the section titles should immediately snap to their indented positions.


1.3.1 Table Of Figures

Generating tables of figures is a little more work than generating the table of contents, but is still pretty easy. If you want to label a drawing or other feature as a figure:

· Select the object (figure) you want to label (in particular, make sure that you have selected the trailing paragraph mark.

· Pull down the Insert menu and select Caption… .

· Ensure that the Position: box is not greyed out and reads Below selected item (if the box is greyed out, you have not properly selected the figure you want to label).

· In the Label: box, select Figure.
· Click OK.
This will insert a piece of autotext reading “Figure 3” (for example). To provide the text that will appear in the table of figures:

· Put the insertion point at the end of the text just generated (immediately before the paragraph mark).

· Hit a tab (this is important).

· Type the text you want to appear.

Notice that by default, the figure number is set up to be flush left and the the figure text is indented one inch to line up with the body text. If you’re labelling something which lines up with the body text, just select the caption and adjust all the tabs and indents in the ruler at the top right one inch.

The table of figures in the front matter can be generated in much the same way as the table of contents:

· If this is a new table of figures, put the insertion point before the paragraph mark below the title string ‘Figures’. If the table already exists, click anywhere in the left hand margin next to it (depending on exactly where you click, either all lines in the table will turn black or just the line you clicked next to will turn black and the rest of the table will turn grey).

· Pull down the Insert menu and select Index and Tables… .
· In the resulting window, select the Table of Figures tab.

· Ensure that the Caption Label: box reads Figure.

· Click OK.
· If asked Do you want to replace the selected table of contents, click Yes.
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	If you do a lot of figure caption addition and deletion, you may notice that the figure numbers appear to get out of sync. This is just Word being lazy about placeholder expansion. It does have one nasty side effect though in that a table generated from these unrefreshed figure numbers is equally unrefreshed and may not look anything like what you want. To restore sanity to your world, follow the refresh strategy outlined in the introduction.
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The following figure was taken from our PDR document to demonstrate how a figure might look. Because the figure is designed to match the body text margins, I shifted the figure caption over as I described in the text.

Figure 1
Baseline Architecture

1.3.2 Other Tables

To generate a table of tables (yuch), follow the instructions for generating a table of figures except that wherever a window gives you a choice of label (Figure, Table, Equation in the Insert/Caption… window or Figure, Table, Equation in the Insert/Index and Tables/Table of Figures window) select type Table instead.

1.4 The Front Page

Ignoring the assorted decorations, the front page is built around two objects, a document description table and a document abstract.

1.4.0 The Document Description Table

The document description table looks something like this:

	Template For An Internal Document

	
	

	Type:
	Document Template

	Version:
	V0-0-0

	Author:
	A.P.Waite

	Created:
	18 January 2002

	Updated:
	22 January 2002

	Printed:
	18 January 2002

	
	


Table 1
The document description table
As described in the introduction, many of these text fields are not what they seem. If you were to hit Alt-F9, the above table would look something like:

	{ TITLE  \* MERGEFORMAT }

	
	

	Type:
	Document Template

	Version:
	{ COMMENTS  \* MERGEFORMAT }

	Author:
	{ AUTHOR  \* MERGEFORMAT }

	Created:
	{ CREATEDATE \@ "d MMMM yyyy" \* MERGEFORMAT }

	Updated:
	{ SAVEDATE \@ "d MMMM yyyy" \* MERGEFORMAT }

	Printed:
	{ PRINTDATE \@ "d MMMM yyyy" \* MERGEFORMAT }

	
	


Table 2
The document description table before field substitution

Six fields are in fact placeholders. Three of these fields (title, author and version) can be edited in the properties page (pull down the File menu and select Properties). Notice that there is no ‘version’ field in the properties page, so I have usurped the ‘Comments’ field for the version number. The date fields are fully automated.
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	I’m a little concerned that the date fields may not update the way one would expect. It seems that any save operation changes the save date even if the document content is unchanged (Word thinks a document needs resaving even if the only thing you changed is a print option). Likewise I’m not clear how the creation date is maintained. The print date could be quite useful … it should solve disagreements about what version a printed copy corresponds to, though it’s largely meaningless if you’re looking at this on a screen.


1.4.1 The Document Abstract

There’s nothing particularly clever about the document abstract. It’s there to provide the writer with a place to put a longer document description. I’ve detailed it here only to point out that it comes with its own style called Abstract.

1.5 Headers And Footers

This is one place where Word fields really paid off. Follow the rules for starting a new section with a Heading 1 style and a document writer should never need to touch the text in the headers and footers. Every piece of text is generated as a Word field.

1.6 Sidebars

Sidebars are those handy little devices which put an icon in the margin and then set off a piece of text to go with it. They’re useful for inserting a piece of text which is relevant to what’s being discussed but which doesn’t really belong in the main flow. For the technically minded, they’re implemented as a two column single row table with the icon in the left hand column (formatted with style Icon) and the text in the right hand colum (formatted with style Icontext). The simplest way to use them is to keep one copy of each type at the end of the document and then copy and paste them into the location where you want them. They come in three varieties:
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	An informational sidebar.
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	A warning sidebar. Typically used to document some kind of misfeature.
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	A ‘severe tire damage’ sidebar. Typically used to document a gross misfeature which could really ruin someone’s day.


1.7 Assorted

One goal of this exercise was to remove uncounted numbers of unused styles. You may notice that the style list in this template is considerably shorter than you are used to. On the other hand I have added a few extra styles to support code documentation. The first table that follows is a list of styles writers might find useful. The second table lists those styles used to support purely internal formatting tasks and which writers will probably never use.

	Style
	Use

	Abstract
	For the abstract on the front page

	Code Numbered
	For code examples (see next section)

	Code Not Numbered
	For code examples (see next section)

	Code Wide Numbered
	For code examples (see next section)

	Code Wide Not Numbered
	For code examples (see next section)

	Interface
	To highlight a piece of text as a window interface element (menu names, menu items, etc.) This is a character style.

	Monotype
	To highlight a piece of text in monotype (useful in body text for filenames, terminal commands, etc.). This is a character style.

	Table Text
	A very vanilla formatting. A useful starting point for text appearing in tables (like this one)


Table 3
Additional useful styles

	Style
	Use

	Caption
	For figure/table captions

	Footer
	For the page footer

	Header
	For the page header

	Icon
	For the icon in a sidebar

	Icontext
	For the text of a sidebar

	Table Heading
	For the table titles in the front matter

	Table of Figures
	For the individual lines of figure/table tables


Table 4
Utility styles used internally

2 Embedding Code

One of the primary uses foreseen for this document template is the construction of user manuals which usually involves the embedding of code or session extracts. This template provides two pairs of styles specifically geared toward code annotation. The only difference between the pairs is the width of the code box produced. Styles Code Not Numbered and Code Numbered produce a code box in line the the standard body text but code lines are limited to 67 characters. Styles Code Wide Not Numbered and Code Wide Numbered stretch the code box from margin to margin and code lines can be a maximum of 79 characters long (I tried for the canonical 80, but I just couldn’t make it fit and keep the font readable).

2.0 Grabbing And Formatting Extracts

I shan’t detail how to get an extract into the document … I’m sure everyone knows how to cut and paste (or you could even free hand the extract if you like). The problem is that the result is usually pretty ugly. The following was free handed just to give you the idea:

#include <stdio.h>

int main()

{

    printf( “Hello World\n” );

    return( 0 );

}

To convert these lines to a simple code box:

· Select all the lines comprising the extract.

· Apply the Code Not Numbered style.

#include <stdio.h>

int main()

{

    printf( “Hello World\n” );

    return( 0 );

}

Which is really pretty easy.

To go on and annotate specific lines in the extract:

· Click in the left margin to highlight the first line you want to annotate.

· Apply the Code Numbered style.

· Repeat until you’ve added numbers to all the lines you want to annotate.

· If you number a line in error, put its style back to Code Not Numbered.

Doing this to the first fourth and fifth lines in the example produces:

0 #include <stdio.h>

int main()

{

1     printf( “Hello World\n” );

2     return( 0 );

}

An example like this can be backed up with a numbered list to form the annotations:

0 The header file where printf is defined.

1 The line that does the real work.

2 In Unix land, a zero return code means success.

As a final hurrah, the extract can be added to the table of figures:

3 #include <stdio.h>

int main()

{

4     printf( “Hello World\n” );

5     return( 0 );

}

Figure 2
A fully annotated code extract (badly numbered)

Whoops. After the copy and paste of the example the code annotation numbers kept going up! To be fair to Word, it can’t tell when to restart numbering a list, so it has to be told. Having said that, it’s a shame that Word seems to have a bug which prevents you from doing this straightforwardly. The recipe to restart numbering should be easy:

· Click in the left margin to select the first numbered line.

· Pull down the Format menu and select Bullets and Numbering… .

· In the Numbered tab, select the Restart numbering radio button.

· Click OK.

Life is never that easy of course … the Restart numbering button is greyed out for the first line in an example like this (though strangely enough, not for subsequent annotated lines). What you really have to do to restart the numbering:

· Click in the left margin to select the first annotated line.

· Duplicate the line (cut and paste will do).

· Click in the left margin to select the second version of the line.

· Pull down the Format menu and select Bullets and Numbering… .

· In the Numbered tab, select the Restart numbering radio button (it’s not greyed out).

· Click OK.

· Go back and delete the first line of the duplicated pair.

· Complain to M$ and ask them to get their act together.
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	Interestingly, the same numbering effect occurs if you copy the annotations down as well, but for some reason it’s possible to simply select the first line of the annotations and request that Word restart numbering without all the mess of duplicating then removing a line. Go figure.


Gather your patience, follow the recipe and you should end up with:

6 #include <stdio.h>

int main()

{

7     printf( “Hello World\n” );

8     return( 0 );

}

Figure 3
A fully annotated “Hello World” program 

0 The header file where printf is defined.

1 The line that does the real work.

2 In Unix land, a zero return code means success.
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